most-5.0.0a-r1.ebuild 902 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Paging program that displays, one windowful at a time, the contents of a file"
  6. HOMEPAGE="ftp://space.mit.edu/pub/davis/most"
  7. SRC_URI="ftp://space.mit.edu/pub/davis/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~mips ~ppc64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE=""
  12. RDEPEND=">=sys-libs/slang-2.1.3"
  13. DEPEND="${RDEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${PN}-5.0.0a-no-explicit-termcap.patch
  16. epatch "${FILESDIR}"/${PN}-5.0.0a-donot-hardcode-path.patch
  17. sed -i -e 's:$(INSTALL) -s:$(INSTALL):' src/Makefile.in || die
  18. export MAKEOPTS+=" -j1"
  19. }
  20. src_configure() {
  21. unset ARCH
  22. econf
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
  26. install
  27. }