osinfo-db-20170326.ebuild 641 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="osinfo database files"
  5. HOMEPAGE="http://libosinfo.org/"
  6. SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
  7. S="${WORKDIR}"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
  11. RDEPEND=""
  12. DEPEND="${RDEPEND}
  13. sys-apps/osinfo-db-tools
  14. "
  15. # we don't depend on intltool here, contrary to README, as the tarball already
  16. # contains the processed results with translations in XML files
  17. src_unpack() { :; }
  18. src_install() {
  19. osinfo-db-import --root "${D}" --dir "/usr/share/osinfo" "${DISTDIR}/${A}"
  20. }