123456789101112131415161718192021222324252627282930313233343536373839404142 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit toolchain-funcs eutils
- DESCRIPTION="tool for easily renaming files"
- HOMEPAGE="http://rename.sourceforge.net/"
- SRC_URI="http://${PN}/sourceforge.net/${P}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
- IUSE=""
- PATCHES=(
- "${FILESDIR}"/${P}-rename.patch
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-gcc44.patch
- )
- src_prepare() {
- sed -i \
- -e '/^CFLAGS/s:-O3:@CFLAGS@:' \
- -e '/strip /s:.*::' \
- Makefile.in || die
- epatch "${PATCHES[@]}"
- tc-export CC
- }
- src_install() {
- newbin rename renamexm
- newman rename.1 renamexm.1
- dodoc README ChangeLog
- }
- pkg_postinst() {
- ewarn "This has been renamed to 'renamexm' to avoid"
- ewarn "a naming conflict with sys-apps/util-linux."
- }
|