rename-1.3.ebuild 901 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs eutils
  4. DESCRIPTION="tool for easily renaming files"
  5. HOMEPAGE="http://rename.sourceforge.net/"
  6. SRC_URI="http://${PN}/sourceforge.net/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  10. IUSE=""
  11. src_unpack() {
  12. unpack ${A}
  13. cd "${S}"
  14. sed -i \
  15. -e '/^CFLAGS/s:-O3:@CFLAGS@:' \
  16. -e '/strip /s:.*::' \
  17. Makefile.in
  18. epatch "${FILESDIR}"/${P}-rename.patch
  19. epatch "${FILESDIR}"/${P}-build.patch
  20. epatch "${FILESDIR}"/${P}-gcc44.patch
  21. tc-export CC
  22. }
  23. src_install() {
  24. newbin rename renamexm || die
  25. newman rename.1 renamexm.1
  26. dodoc README ChangeLog
  27. }
  28. pkg_postinst() {
  29. ewarn "This has been renamed to 'renamexm' to avoid"
  30. ewarn "a naming conflict with sys-apps/util-linux."
  31. }