restartd-0.2.2.ebuild 710 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils toolchain-funcs
  5. MY_PV=${PV/_alpha/.a-}
  6. DESCRIPTION="A daemon for checking your running and not running processes"
  7. HOMEPAGE="http://packages.debian.org/unstable/utils/restartd"
  8. SRC_URI="mirror://debian/pool/main/r/restartd/${PN}_${MY_PV}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~x86"
  12. IUSE=""
  13. src_prepare() {
  14. sed -i Makefile -e 's|-o restartd|$(LDFLAGS) &|g' || die "sed Makefile"
  15. }
  16. src_compile() {
  17. emake CC=$(tc-getCC) C_ARGS="${CFLAGS}" || die
  18. }
  19. src_install() {
  20. dodir /etc /usr/sbin /usr/share/man/man8 /usr/share/man/fr/man8/
  21. emake DESTDIR="${D}" install || die
  22. }