s6-portable-utils-2.0.6.0.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Set of tiny portable unix utilities"
  5. HOMEPAGE="http://www.skarnet.org/software/s6-portable-utils/"
  6. SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
  7. LICENSE="ISC"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="static"
  11. DEPEND="
  12. static? ( >=dev-libs/skalibs-2.3.10.0[static-libs] )
  13. !static? ( >=dev-libs/skalibs-2.3.10.0 )
  14. "
  15. RDEPEND="
  16. !static? ( >=dev-libs/skalibs-2.3.10.0 )
  17. "
  18. HTML_DOCS="doc/."
  19. src_prepare()
  20. {
  21. # Remove QA warning about LDFLAGS addition
  22. sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
  23. eapply_user
  24. }
  25. src_configure()
  26. {
  27. econf \
  28. $(use_enable !static shared) \
  29. $(use_enable static allstatic) \
  30. $(use_enable static) \
  31. --bindir=/bin \
  32. --sbindir=/sbin \
  33. --dynlibdir=/$(get_libdir) \
  34. --libdir=/usr/$(get_libdir)/${PN} \
  35. --datadir=/etc \
  36. --sysdepdir=/usr/$(get_libdir)/${PN} \
  37. --with-dynlib=/$(get_libdir) \
  38. --with-sysdeps=/usr/$(get_libdir)/skalibs
  39. }