setserial-2.17-r4.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="Configure your serial ports with it"
  5. HOMEPAGE="http://setserial.sourceforge.net/"
  6. SRC_URI="ftp://tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz
  7. ftp://ftp.sunsite.org.uk/Mirrors/tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
  11. IUSE=""
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. epatch "${FILESDIR}"/${P}-spelling.patch
  16. epatch "${FILESDIR}"/${P}-manpage-updates.patch
  17. epatch "${FILESDIR}"/${P}-headers.patch
  18. epatch "${FILESDIR}"/${P}-build.patch
  19. epatch "${FILESDIR}"/${P}-hayes-esp.patch #309883
  20. epatch "${FILESDIR}"/${P}-darwin.patch #541536
  21. }
  22. src_compile() {
  23. tc-export CC
  24. econf || die
  25. emake setserial || die
  26. }
  27. src_install() {
  28. doman setserial.8
  29. into /
  30. dobin setserial || die
  31. insinto /etc
  32. doins serial.conf
  33. newinitd "${FILESDIR}"/serial-2.17-r4 serial
  34. dodoc README
  35. docinto txt
  36. dodoc Documentation/*
  37. }