sg3_utils-1.40.ebuild 958 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils multilib
  5. DESCRIPTION="Apps for querying the sg SCSI interface"
  6. HOMEPAGE="http://sg.danny.cz/sg/"
  7. SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
  11. IUSE="static-libs"
  12. DEPEND="sys-devel/libtool"
  13. RDEPEND=""
  14. PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
  17. }
  18. src_configure() {
  19. econf $(use_enable static-libs static)
  20. }
  21. src_install() {
  22. default
  23. dodoc COVERAGE doc/README examples/*.txt
  24. newdoc scripts/README README.scripts
  25. # Better fix for bug 231089; some packages look for sgutils2
  26. local path lib
  27. path="/usr/$(get_libdir)"
  28. for lib in "${ED}"${path}/libsgutils2.*; do
  29. lib=${lib##*/}
  30. dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
  31. done
  32. prune_libtool_files
  33. }