syslog-notify-0.2.ebuild 966 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit readme.gentoo
  5. DESCRIPTION="Notifications for syslog entries via libnotify"
  6. HOMEPAGE="https://jtniehof.github.com/syslog-notify/"
  7. SRC_URI="mirror://github/jtniehof/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND=">=x11-libs/libnotify-0.7"
  13. RDEPEND="${DEPEND}
  14. || ( app-admin/syslog-ng app-admin/rsyslog )"
  15. pkg_setup() {
  16. DOCS="AUTHORS CHANGELOG HACKING README"
  17. DISABLE_AUTOFORMATTING="yes"
  18. DOC_CONTENTS="Add the following options on your /etc/syslog-ng/syslog-ng.conf
  19. file:
  20. # destination notify { pipe("/var/spool/syslog-notify"); };
  21. # log { source(src); destination(notify);};
  22. Remember to restart syslog-ng before starting syslog-notify."
  23. }
  24. src_install() {
  25. default
  26. dodir /var/spool
  27. readme.gentoo_create_doc
  28. }
  29. pkg_postinst() {
  30. mkfifo "${EROOT}"/var/spool/syslog-notify
  31. readme.gentoo_print_elog
  32. }