texinfo-5.2.ebuild 945 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit flag-o-matic
  5. DESCRIPTION="The GNU info program and utilities"
  6. HOMEPAGE="https://www.gnu.org/software/texinfo/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  11. IUSE="nls static"
  12. RDEPEND="!=app-text/tetex-2*
  13. >=sys-libs/ncurses-5.2-r2
  14. dev-lang/perl
  15. dev-perl/libintl-perl
  16. dev-perl/Unicode-EastAsianWidth
  17. dev-perl/Text-Unidecode
  18. nls? ( virtual/libintl )"
  19. DEPEND="${RDEPEND}
  20. app-arch/xz-utils
  21. nls? ( sys-devel/gettext )"
  22. src_configure() {
  23. use static && append-ldflags -static
  24. econf \
  25. --with-external-libintl-perl \
  26. --with-external-Unicode-EastAsianWidth \
  27. --with-external-Text-Unidecode \
  28. $(use_enable nls)
  29. }
  30. src_install() {
  31. default
  32. newdoc info/README README.info
  33. }