texinfo-6.3.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # Note: if your package uses the texi2dvi utility, it must depend on the
  4. # virtual/texi2dvi package to pull in all the right deps. The tool is not
  5. # usable out-of-the-box because it requires the large tex packages.
  6. EAPI="5"
  7. inherit flag-o-matic
  8. DESCRIPTION="The GNU info program and utilities"
  9. HOMEPAGE="https://www.gnu.org/software/texinfo/"
  10. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
  11. LICENSE="GPL-3"
  12. SLOT="0"
  13. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  14. IUSE="nls static"
  15. RDEPEND="
  16. !=app-text/tetex-2*
  17. >=sys-libs/ncurses-5.2-r2:0=
  18. dev-lang/perl:=
  19. dev-perl/libintl-perl
  20. dev-perl/Unicode-EastAsianWidth
  21. dev-perl/Text-Unidecode
  22. nls? ( virtual/libintl )"
  23. DEPEND="${RDEPEND}
  24. app-arch/xz-utils
  25. nls? ( >=sys-devel/gettext-0.19.6 )"
  26. src_configure() {
  27. use static && append-ldflags -static
  28. econf \
  29. --with-external-libintl-perl \
  30. --with-external-Unicode-EastAsianWidth \
  31. --with-external-Text-Unidecode \
  32. $(use_enable nls)
  33. }