tuned-2.7.1-r2.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1 systemd
  6. DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
  7. HOMEPAGE="https://fedorahosted.org/tuned/"
  8. SRC_URI="https://fedorahosted.org/releases/t/u/tuned/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. COMMON_DEPEND="${PYTHON_DEPS}
  14. dev-python/configobj[${PYTHON_USEDEP}]
  15. dev-python/decorator[${PYTHON_USEDEP}]
  16. dev-python/pyudev[${PYTHON_USEDEP}]
  17. dev-python/dbus-python[${PYTHON_USEDEP}]
  18. dev-python/pygobject:3[${PYTHON_USEDEP}]
  19. "
  20. DEPEND="${COMMON_DEPEND}"
  21. RDEPEND="${COMMON_DEPEND}
  22. sys-apps/dbus
  23. sys-apps/ethtool
  24. sys-power/powertop
  25. sys-process/procps
  26. dev-util/systemtap
  27. "
  28. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  29. src_prepare() {
  30. epatch "${FILESDIR}"/${P}-sysctl.patch
  31. epatch "${FILESDIR}"/${P}-makefile-rpm.patch
  32. sed -i \
  33. -e "/\$(DESTDIR)\/run\/tuned/d" \
  34. Makefile ||die
  35. }
  36. src_install() {
  37. default
  38. newinitd "${FILESDIR}"/tuned.initd tuned
  39. python_fix_shebang "${ED}"
  40. }