ucspi-proxy-0.98.ebuild 865 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit toolchain-funcs multilib
  5. DESCRIPTION="proxy program for two connections set up by a UCSPI server and a UCSPI client"
  6. HOMEPAGE="http://untroubled.org/ucspi-proxy/"
  7. SRC_URI="http://untroubled.org/ucspi-proxy/archive/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~x86"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/bglibs-1.106"
  13. DEPEND="${RDEPEND}"
  14. src_prepare() {
  15. sed -i -e '/^>bin$/ac:::755::ucspi-proxy' INSTHIER
  16. }
  17. src_configure() {
  18. echo "$(tc-getCC) ${CFLAGS}" > conf-cc
  19. echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
  20. echo "${D}/usr/bin" > conf-bin
  21. echo "${D}/usr/share/man" > conf-man
  22. echo "/usr/include/bglibs" > conf-bgincs
  23. echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
  24. }
  25. src_install() {
  26. einstall || die
  27. dodoc ANNOUNCEMENT NEWS README TODO
  28. }