usbredir-0.7.ebuild 840 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic
  5. DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
  6. HOMEPAGE="http://spice-space.org/page/UsbRedir"
  7. SRC_URI="http://spice-space.org/download/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2 LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
  11. IUSE="static-libs"
  12. RDEPEND=">=dev-libs/libusb-1.0.19"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. DOCS="ChangeLog README* TODO *.txt"
  16. src_configure() {
  17. # https://bugs.freedesktop.org/show_bug.cgi?id=54643
  18. append-cflags -Wno-error
  19. econf $(use_enable static-libs static)
  20. }
  21. src_install() {
  22. default
  23. prune_libtool_files
  24. # noinst_PROGRAMS
  25. dobin usbredirtestclient/.libs/usbredirtestclient
  26. }