usbredir-9999.ebuild 842 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic autotools git-2
  5. DESCRIPTION="A simple TCP daemon and set of libraries for the usbredir protocol (redirecting USB traffic)"
  6. HOMEPAGE="http://spice-space.org/page/UsbRedir"
  7. EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/usbredir.git"
  8. LICENSE="GPL-2 LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS=""
  11. IUSE="static-libs"
  12. RDEPEND="virtual/libusb:1"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. DOCS="ChangeLog README* TODO *.txt"
  16. EGIT_BOOTSTRAP="eautoreconf"
  17. src_configure() {
  18. # https://bugs.freedesktop.org/show_bug.cgi?id=54643
  19. append-cflags -Wno-error
  20. econf $(use_enable static-libs static)
  21. }
  22. src_install() {
  23. default
  24. prune_libtool_files
  25. # noinst_PROGRAMS
  26. dobin usbredirtestclient/usbredirtestclient
  27. }