watchdog-5.14.ebuild 869 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs flag-o-matic systemd
  5. DESCRIPTION="A software watchdog and /dev/watchdog daemon"
  6. HOMEPAGE="https://sourceforge.net/projects/watchdog/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm m68k ~mips ppc s390 sh ~sparc x86"
  11. IUSE="nfs"
  12. DEPEND="nfs? ( net-libs/libtirpc )"
  13. RDEPEND="${DEPEND}"
  14. src_configure() {
  15. if use nfs ; then
  16. tc-export PKG_CONFIG
  17. append-cppflags $(${PKG_CONFIG} libtirpc --cflags)
  18. export LIBS+=" $(${PKG_CONFIG} libtirpc --libs)"
  19. fi
  20. econf $(use_enable nfs)
  21. }
  22. src_install() {
  23. default
  24. docinto examples
  25. dodoc examples/*
  26. newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
  27. newinitd "${FILESDIR}"/${PN}-init.d ${PN}
  28. systemd_dounit "${FILESDIR}"/watchdog.service
  29. }