lsiutil-1.62-r1.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. DESCRIPTION="LSI Logic Fusion MPT Command Line Interface management tool"
  5. HOMEPAGE="http://www.lsi.com/"
  6. SRC_URI="http://www.lsi.com/downloads/Public/Obsolete/Obsolete%20Common%20Files/LSIUtil_${PV}.zip"
  7. LICENSE="LSI"
  8. SLOT="0"
  9. # This package can never enter stable, it can't be mirrored and upstream
  10. # can remove the distfiles from their mirror anytime.
  11. KEYWORDS="~amd64 ~ia64 ~x86"
  12. IUSE=""
  13. RESTRICT="fetch mirror bindist"
  14. RDEPEND=""
  15. DEPEND="app-arch/unzip"
  16. QA_PRESTRIPPED="/opt/bin/lsiutil"
  17. S="${WORKDIR}"
  18. pkg_nofetch() {
  19. einfo "Upstream has implemented a mandatory clickthrough EULA for distfile download"
  20. einfo "Please visit $SRC_URI"
  21. einfo "And place $A in ${DISTDIR}"
  22. }
  23. src_install() {
  24. exeinto /opt/bin
  25. if use x86; then
  26. doexe Linux/lsiutil || die
  27. elif use amd64; then
  28. newexe Linux/lsiutil.x86_64 lsiutil
  29. elif use ia64; then
  30. newexe Linux/lsiutil.ia64 lsiutil
  31. fi
  32. dodoc changes.txt
  33. }