ms-sys-2.4.0.ebuild 686 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="A command-line program for writing Microsoft compatible boot records"
  6. HOMEPAGE="http://ms-sys.sourceforge.net"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="linguas_sv"
  12. DEPEND="sys-devel/gettext"
  13. RDEPEND="virtual/libintl"
  14. src_compile() {
  15. tc-export CC
  16. default
  17. }
  18. src_install() {
  19. local nls=""
  20. if ! use linguas_sv ; then
  21. nls='NLS_FILES='
  22. fi
  23. emake DESTDIR="${D}" MANDIR="/usr/share/man" \
  24. PREFIX="/usr" ${nls} install
  25. dodoc CHANGELOG CONTRIBUTORS FAQ README TODO
  26. }