keepalived-1.2.19.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
  6. HOMEPAGE="http://www.keepalived.org/"
  7. SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~s390 ~sparc x86"
  11. IUSE="debug ipv6 snmp"
  12. RDEPEND="dev-libs/popt
  13. sys-apps/iproute2
  14. dev-libs/libnl:=
  15. dev-libs/openssl:=
  16. snmp? ( net-analyzer/net-snmp )"
  17. DEPEND="${RDEPEND}
  18. >=sys-kernel/linux-headers-2.6.30"
  19. PATCHES=(
  20. "${FILESDIR}"/${PN}-1.2.2-libipvs-fix-backup-daemon.patch
  21. )
  22. DOCS=( README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
  23. doc/keepalived.conf.SYNOPSIS doc/NOTE_vrrp_vmac.txt )
  24. src_prepare() {
  25. eautoreconf
  26. }
  27. src_configure() {
  28. STRIP=/bin/true \
  29. econf \
  30. --with-kernel-dir=/usr \
  31. --enable-vrrp \
  32. $(use_enable debug) \
  33. $(use_enable snmp)
  34. }
  35. src_install() {
  36. default
  37. newinitd "${FILESDIR}"/keepalived.init keepalived
  38. newconfd "${FILESDIR}"/keepalived.confd keepalived
  39. use snmp && dodoc doc/KEEPALIVED-MIB
  40. docinto genhash
  41. dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION
  42. # This was badly named by upstream, it's more HOWTO than anything else.
  43. newdoc INSTALL INSTALL+HOWTO
  44. # Security risk to bundle SSL certs
  45. rm -f "${ED}"/etc/keepalived/samples/*.pem
  46. # Clean up sysvinit files
  47. rm -rf "${ED}"/etc/sysconfig "${ED}"/etc/rc.d/
  48. }