keepalived-1.2.22.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
  6. HOMEPAGE="http://www.keepalived.org/"
  7. SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
  11. IUSE="debug ipv6 snmp"
  12. RDEPEND="dev-libs/popt
  13. sys-apps/iproute2
  14. dev-libs/libnl:=
  15. dev-libs/openssl:=
  16. snmp? ( net-analyzer/net-snmp )
  17. net-libs/libnfnetlink"
  18. DEPEND="${RDEPEND}
  19. >=sys-kernel/linux-headers-2.6.30"
  20. PATCHES=(
  21. "${FILESDIR}"/${PN}-1.2.2-libipvs-fix-backup-daemon.patch
  22. )
  23. DOCS=( README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
  24. doc/keepalived.conf.SYNOPSIS doc/NOTE_vrrp_vmac.txt )
  25. src_prepare() {
  26. eautoreconf
  27. default
  28. }
  29. src_configure() {
  30. STRIP=/bin/true \
  31. econf \
  32. --with-kernel-dir=/usr \
  33. --enable-vrrp \
  34. $(use_enable debug) \
  35. $(use_enable snmp)
  36. }
  37. src_install() {
  38. default
  39. newinitd "${FILESDIR}"/keepalived.init keepalived
  40. newconfd "${FILESDIR}"/keepalived.confd keepalived
  41. use snmp && dodoc doc/KEEPALIVED-MIB
  42. docinto genhash
  43. dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION
  44. # This was badly named by upstream, it's more HOWTO than anything else.
  45. newdoc INSTALL INSTALL+HOWTO
  46. # Security risk to bundle SSL certs
  47. rm -f "${ED}"/etc/keepalived/samples/*.pem
  48. # Clean up sysvinit files
  49. rm -rf "${ED}"/etc/sysconfig "${ED}"/etc/rc.d/
  50. }