keepalived-1.2.24.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
  6. HOMEPAGE="http://www.keepalived.org/"
  7. SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~s390 sparc x86"
  11. IUSE="debug ipv6 snmp"
  12. RDEPEND="dev-libs/popt
  13. sys-apps/iproute2
  14. dev-libs/libnl:=
  15. dev-libs/openssl:=
  16. snmp? ( net-analyzer/net-snmp )
  17. net-libs/libnfnetlink"
  18. DEPEND="${RDEPEND}
  19. >=sys-kernel/linux-headers-4.4"
  20. DOCS=( README CONTRIBUTORS INSTALL ChangeLog AUTHOR TODO
  21. doc/keepalived.conf.SYNOPSIS doc/NOTE_vrrp_vmac.txt )
  22. src_prepare() {
  23. eautoreconf
  24. default
  25. }
  26. src_configure() {
  27. STRIP=/bin/true \
  28. econf \
  29. --with-kernel-dir=/usr \
  30. --enable-vrrp \
  31. $(use_enable debug) \
  32. $(use_enable snmp)
  33. }
  34. src_install() {
  35. default
  36. newinitd "${FILESDIR}"/keepalived.init keepalived
  37. newconfd "${FILESDIR}"/keepalived.confd keepalived
  38. use snmp && dodoc doc/KEEPALIVED-MIB
  39. docinto genhash
  40. dodoc genhash/README genhash/AUTHOR genhash/ChangeLog
  41. # This was badly named by upstream, it's more HOWTO than anything else.
  42. newdoc INSTALL INSTALL+HOWTO
  43. # Security risk to bundle SSL certs
  44. rm -f "${ED}"/etc/keepalived/samples/*.pem
  45. # Clean up sysvinit files
  46. rm -rf "${ED}"/etc/sysconfig "${ED}"/etc/rc.d/
  47. }