legion-16.08.0-r1.ebuild 842 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="A data-centric parallel programming system"
  6. HOMEPAGE="http://legion.stanford.edu/"
  7. SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="gasnet +hwloc"
  12. DEPEND="
  13. gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
  14. hwloc? ( sys-apps/hwloc )
  15. "
  16. S="${WORKDIR}/${PN}-${P}"
  17. #https://github.com/StanfordLegion/legion/pull/166
  18. #https://github.com/StanfordLegion/legion/pull/167
  19. PATCHES=( "${FILESDIR}/${P}-hwloc.patch" "${FILESDIR}/${P}-multilib.patch" )
  20. src_configure() {
  21. mycmakeargs=(
  22. -DLegion_USE_HWLOC=$(usex hwloc)
  23. -DLegion_USE_GASNet=$(usex gasnet)
  24. -DBUILD_SHARED_LIBS=ON
  25. -DLIB=$(get_libdir)
  26. )
  27. cmake-utils_src_configure
  28. }