legion-16.10.0.ebuild 669 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="A data-centric parallel programming system"
  6. HOMEPAGE="http://legion.stanford.edu/"
  7. SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="gasnet +hwloc"
  12. DEPEND="
  13. gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
  14. hwloc? ( sys-apps/hwloc )
  15. "
  16. S="${WORKDIR}/${PN}-${P}"
  17. src_configure() {
  18. mycmakeargs=(
  19. -DLegion_USE_HWLOC=$(usex hwloc)
  20. -DLegion_USE_GASNet=$(usex gasnet)
  21. -DBUILD_SHARED_LIBS=ON
  22. -DLegion_BUILD_EXAMPLES=ON
  23. )
  24. cmake-utils_src_configure
  25. }