autogen-5.18.10.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Program and text file generation"
  6. HOMEPAGE="https://www.gnu.org/software/autogen/"
  7. SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
  11. IUSE="libopts static-libs"
  12. # This should be guile-1.8+, but upstream has a bug with older versions:
  13. # https://savannah.gnu.org/support/index.php?109051
  14. RDEPEND=">=dev-scheme/guile-2.0:=
  15. dev-libs/libxml2"
  16. DEPEND="${RDEPEND}"
  17. src_prepare() {
  18. # https://savannah.gnu.org/support/index.php?109050
  19. sed -i \
  20. -e "/--cflags-only-I/s:pkg-config:$(tc-getPKG_CONFIG):" \
  21. configure || die
  22. }
  23. src_configure() {
  24. # suppress possibly incorrect -R flag
  25. export ag_cv_test_ldflags=
  26. econf $(use_enable static-libs static)
  27. }
  28. src_install() {
  29. default
  30. prune_libtool_files
  31. if ! use libopts ; then
  32. rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
  33. fi
  34. }