make-4.1-r1.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit flag-o-matic eutils
  5. DESCRIPTION="Standard tool to compile source trees"
  6. HOMEPAGE="https://www.gnu.org/software/make/make.html"
  7. SRC_URI="mirror://gnu//make/${P}.tar.bz2"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="guile nls static"
  12. CDEPEND="guile? ( >=dev-scheme/guile-1.8 )"
  13. DEPEND="${CDEPEND}
  14. nls? ( sys-devel/gettext )"
  15. RDEPEND="${CDEPEND}
  16. nls? ( virtual/libintl )"
  17. src_prepare() {
  18. epatch \
  19. "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch \
  20. "${FILESDIR}"/${P}-fix_null_returns_from_ttyname.patch
  21. }
  22. src_configure() {
  23. use static && append-ldflags -static
  24. econf \
  25. --program-prefix=g \
  26. $(use_with guile) \
  27. $(use_enable nls)
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" install
  31. dodoc AUTHORS NEWS README*
  32. if [[ ${USERLAND} == "GNU" ]] ; then
  33. # we install everywhere as 'gmake' but on GNU systems,
  34. # symlink 'make' to 'gmake'
  35. dosym gmake /usr/bin/make
  36. dosym gmake.1 /usr/share/man/man1/make.1
  37. fi
  38. }