make-4.2.1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic eutils
  5. DESCRIPTION="Standard tool to compile source trees"
  6. HOMEPAGE="https://www.gnu.org/software/make/make.html"
  7. SRC_URI="mirror://gnu//make/${P}.tar.bz2"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="guile nls static"
  12. CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
  13. DEPEND="${CDEPEND}
  14. nls? ( sys-devel/gettext )"
  15. RDEPEND="${CDEPEND}
  16. nls? ( virtual/libintl )"
  17. PATCHES=(
  18. "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
  19. )
  20. src_prepare() {
  21. epatch "${PATCHES[@]}"
  22. }
  23. src_configure() {
  24. use static && append-ldflags -static
  25. econf \
  26. --program-prefix=g \
  27. $(use_with guile) \
  28. $(use_enable nls)
  29. }
  30. src_install() {
  31. emake DESTDIR="${D}" install
  32. dodoc AUTHORS NEWS README*
  33. if [[ ${USERLAND} == "GNU" ]] ; then
  34. # we install everywhere as 'gmake' but on GNU systems,
  35. # symlink 'make' to 'gmake'
  36. dosym gmake /usr/bin/make
  37. dosym gmake.1 /usr/share/man/man1/make.1
  38. fi
  39. }