dosfstools-4.1.ebuild 1012 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit toolchain-funcs flag-o-matic
  5. DESCRIPTION="DOS filesystem tools - provides mkdosfs, mkfs.msdos, mkfs.vfat"
  6. HOMEPAGE="https://github.com/dosfstools/dosfstools"
  7. SRC_URI="https://github.com/dosfstools/dosfstools/releases/download/v${PV}/${P}.tar.xz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
  11. IUSE="compat test +udev"
  12. CDEPEND="udev? ( virtual/libudev )"
  13. DEPEND="${CDEPEND}
  14. test? ( app-editors/vim-core )
  15. udev? ( virtual/pkgconfig )"
  16. RDEPEND="${CDEPEND}"
  17. src_configure() {
  18. econf \
  19. --docdir="${EPREFIX}"/usr/share/doc/${PF} \
  20. $(use_enable compat compat-symlinks) \
  21. $(use_with udev)
  22. }
  23. src_install() {
  24. default
  25. if ! use compat; then
  26. # Keep fsck -t vfat and mkfs -t vfat working, bug 584980.
  27. dosym fsck.fat /usr/sbin/fsck.vfat
  28. dosym mkfs.fat /usr/sbin/mkfs.vfat
  29. fi
  30. }