duperemove-0.11_beta4.ebuild 713 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Btrfs deduplication utility"
  6. HOMEPAGE="https://github.com/markfasheh/duperemove"
  7. SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz -> ${P/_/.}.tar.gz"
  8. # includes code from libbloom, xxhash (BSD-2)
  9. # includes code from polarssl (GPL-2+)
  10. LICENSE="GPL-2 GPL-2+ BSD-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. IUSE=""
  14. RDEPEND="
  15. dev-db/sqlite:3=
  16. dev-libs/glib:2="
  17. DEPEND="${RDEPEND}"
  18. S=${WORKDIR}/${P/_/.}
  19. src_compile() {
  20. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
  21. }
  22. src_install() {
  23. emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
  24. }