e4rat-0.2.4_pre20141201-r1.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils linux-info readme.gentoo-r1
  5. DESCRIPTION="Toolset to accelerate the boot process and application startup"
  6. HOMEPAGE="http://e4rat.sourceforge.net/"
  7. #SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
  8. SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${PN}-0.2.4_pre20141201.tar.xz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RDEPEND="
  14. dev-lang/perl:=
  15. >=dev-libs/boost-1.42:=
  16. sys-fs/e2fsprogs
  17. sys-process/audit[static-libs(+)]
  18. sys-process/lsof
  19. "
  20. DEPEND="${DEPEND}"
  21. CONFIG_CHECK="~AUDITSYSCALL"
  22. PATCHES=(
  23. "${FILESDIR}"/${PN}-0.2.2-shared-build.patch
  24. "${FILESDIR}"/${PN}-0.2.2-libdir.patch
  25. "${FILESDIR}"/${PN}-0.2.4-sysmacros.patch #580534
  26. "${FILESDIR}"/${PN}-0.2.4-gcc6.patch #594046
  27. "${FILESDIR}"/${PN}-0.2.4-strdup.patch
  28. )
  29. pkg_setup() {
  30. check_extra_config
  31. DOC_CONTENTS="
  32. To launch systemd from e4rat you simply need to edit /etc/e4rat.conf
  33. and set:\n
  34. ; path to init process binary (DEFAULT: /sbin/init)\n
  35. init /usr/lib/systemd/systemd"
  36. }
  37. src_install() {
  38. cmake-utils_src_install
  39. # relocate binaries to /sbin. If someone knows of a better way to do it
  40. # please do tell me
  41. dodir sbin
  42. find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
  43. || die
  44. readme.gentoo_create_doc
  45. }
  46. pkg_postinst() {
  47. readme.gentoo_print_elog
  48. if has_version sys-apps/preload; then
  49. elog "It appears you have sys-apps/preload installed. This may"
  50. elog "has negative effects on ${PN}. You may want to disable preload"
  51. elog "when using ${PN}."
  52. fi
  53. }