extundelete-0.2.0-r2.ebuild 691 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. _UNDEL_DEB=2.1
  6. _UNDEL_E2FS=1.42.6
  7. DESCRIPTION="A utility to undelete files from an ext3 or ext4 partition"
  8. HOMEPAGE="http://extundelete.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
  10. mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${_UNDEL_DEB}.debian.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT=0
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. RDEPEND=">=sys-fs/e2fsprogs-${_UNDEL_E2FS}
  16. >=sys-libs/e2fsprogs-libs-${_UNDEL_E2FS}"
  17. DEPEND=${RDEPEND}
  18. DOCS=README
  19. src_prepare() {
  20. local d=${WORKDIR}/debian/patches
  21. EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
  22. }