gfs2-utils-3.1.2.ebuild 916 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools linux-info
  5. DESCRIPTION="GFS2 Utilities"
  6. HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
  7. SRC_URI="https://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug"
  12. RDEPEND="sys-cluster/corosync
  13. sys-cluster/openais
  14. sys-cluster/liblogthread
  15. sys-cluster/libccs
  16. sys-cluster/libfence
  17. sys-cluster/libdlm
  18. sys-libs/ncurses"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. S="${WORKDIR}/${PN}"
  22. src_prepare() {
  23. mkdir m4
  24. eautoreconf
  25. }
  26. src_configure() {
  27. econf \
  28. $(use_enable debug) \
  29. --with-kernel="${KERNEL_DIR}" \
  30. --localstatedir=/var
  31. }
  32. src_install() {
  33. default
  34. rm -rf "${D}/usr/share/doc"
  35. dodoc doc/*.txt
  36. rmdir "${D}"/var/run/{cluster,} # cman-init.d creates it
  37. keepdir /var/{lib,log}/cluster
  38. }