gfs2-utils-3.1.5.ebuild 884 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools linux-info
  5. DESCRIPTION="GFS2 Utilities"
  6. HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
  7. SRC_URI="https://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug"
  12. RDEPEND="sys-cluster/corosync
  13. sys-cluster/openais
  14. sys-cluster/liblogthread
  15. sys-cluster/libccs
  16. sys-cluster/libfence
  17. sys-cluster/libdlm
  18. sys-libs/ncurses"
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig"
  21. S="${WORKDIR}/${PN}"
  22. src_prepare() {
  23. epatch_user
  24. eautoreconf
  25. }
  26. src_configure() {
  27. econf \
  28. $(use_enable debug) \
  29. --localstatedir=/var
  30. }
  31. src_compile() {
  32. # parallel build is broken
  33. emake -j1
  34. }
  35. src_install() {
  36. default
  37. rm -rf "${D}/usr/share/doc"
  38. dodoc doc/*.txt
  39. keepdir /var/{lib,log}/cluster
  40. }