hfsutils-3.2.6-r5.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="HFS FS Access utils"
  6. HOMEPAGE="http://www.mars.org/home/rob/proj/hfs/"
  7. SRC_URI="ftp://ftp.mars.org/pub/hfs/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm ppc ppc64 sparc x86"
  11. IUSE="tcl tk"
  12. DEPEND="
  13. tcl? ( dev-lang/tcl:0= )
  14. tk? ( dev-lang/tk:0= )"
  15. RDEPEND="${DEPEND}"
  16. # use tk requires tcl - bug #150437
  17. REQUIRED_USE="tk? ( tcl )"
  18. src_prepare() {
  19. epatch \
  20. "${FILESDIR}"/${P}-errno.patch \
  21. "${FILESDIR}"/largerthan2gb.patch \
  22. "${FILESDIR}"/${P}-fix-tcl-8.6.patch
  23. }
  24. src_configure() {
  25. econf $(use_with tcl) $(use_with tk)
  26. }
  27. src_compile() {
  28. emake AR="$(tc-getAR) rc" CC="$(tc-getCC)" RANLIB="$(tc-getRANLIB)"
  29. emake CC="$(tc-getCC)" -C hfsck
  30. }
  31. src_install() {
  32. dodir /usr/bin /usr/lib /usr/share/man/man1
  33. emake \
  34. prefix="${D}"/usr \
  35. MANDEST="${D}"/usr/share/man \
  36. infodir="${D}"/usr/share/info \
  37. install
  38. dobin hfsck/hfsck
  39. dodoc BLURB CHANGES README TODO doc/*.txt
  40. }