mhddfs-0.1.39.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit base eutils toolchain-funcs
  5. MY_P="${PN}_${PV}"
  6. DESCRIPTION="Fuse multi harddrive filesystem"
  7. HOMEPAGE="http://mhddfs.uvw.ru/ http://svn.uvw.ru/mhddfs/trunk/README"
  8. SRC_URI="http://mhddfs.uvw.ru/downloads/${MY_P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64"
  12. IUSE="l10n_ru suid"
  13. RDEPEND=">=sys-fs/fuse-2.7.0"
  14. DEPEND="${RDEPEND}
  15. dev-libs/uthash"
  16. DOCS="ChangeLog README"
  17. PATCHES=( "${FILESDIR}/${PN}-respect-compiler-vars.patch" )
  18. src_compile() {
  19. emake CC="$(tc-getCC)"
  20. }
  21. src_install() {
  22. dobin mhddfs
  23. doman mhddfs.1
  24. dodoc ${DOCS}
  25. use l10n_ru && dodoc README.ru.UTF-8
  26. use suid && fperms u+s /usr/bin/${PN}
  27. }
  28. pkg_postinst() {
  29. if use suid; then
  30. ewarn
  31. ewarn "You have chosen to install ${PN} with the binary setuid root. This"
  32. ewarn "means that if there any undetected vulnerabilities in the binary,"
  33. ewarn "then local users may be able to gain root access on your machine."
  34. ewarn
  35. fi
  36. }