mtools-4.0.15.ebuild 832 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit autotools
  5. DESCRIPTION="utilities to access MS-DOS disks from Unix without mounting them"
  6. HOMEPAGE="http://mtools.linux.lu/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
  11. IUSE="X"
  12. DEPEND="
  13. X? (
  14. x11-libs/libICE
  15. x11-libs/libXau
  16. x11-libs/libSM
  17. x11-libs/libX11
  18. x11-libs/libXt
  19. )"
  20. RDEPEND="${DEPEND}"
  21. src_prepare() {
  22. eautoconf #341443
  23. }
  24. src_configure() {
  25. econf \
  26. --sysconfdir=/etc/mtools \
  27. $(use_with X x)
  28. }
  29. src_install() {
  30. emake -j1 DESTDIR="${D}" install || die
  31. insinto /etc/mtools
  32. doins mtools.conf || die
  33. dosed '/^SAMPLE FILE$/s:^:#:' /etc/mtools/mtools.conf # default is fine
  34. dodoc README* Release.notes
  35. }