mtools-4.0.17.ebuild 901 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. DESCRIPTION="utilities to access MS-DOS disks from Unix without mounting them"
  5. HOMEPAGE="http://mtools.linux.lu/"
  6. SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
  7. LICENSE="GPL-3"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE="X"
  11. DEPEND="
  12. X? (
  13. x11-libs/libICE
  14. x11-libs/libXau
  15. x11-libs/libSM
  16. x11-libs/libX11
  17. x11-libs/libXt
  18. )"
  19. RDEPEND="${DEPEND}"
  20. src_prepare() {
  21. # Don't throw errors on existing directories
  22. sed -i -e "s:mkdir:mkdir -p:" mkinstalldirs || die
  23. }
  24. src_configure() {
  25. econf \
  26. --sysconfdir=/etc/mtools \
  27. $(use_with X x)
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" install
  31. dodoc README* Release.notes
  32. insinto /etc/mtools
  33. doins mtools.conf
  34. # default is fine
  35. sed -i -e '/^SAMPLE FILE$/s:^:#:' "${D}"/etc/mtools/mtools.conf || die
  36. }