nilfs-utils-2.2.2.ebuild 787 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib linux-info
  5. DESCRIPTION="A New Implementation of a Log-structured File System for Linux"
  6. HOMEPAGE="http://nilfs.sourceforge.net/"
  7. SRC_URI="http://nilfs.sourceforge.net/download/${P}.tar.bz2"
  8. LICENSE="GPL-2 LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
  11. IUSE="static-libs"
  12. RDEPEND="sys-libs/e2fsprogs-libs
  13. sys-apps/util-linux"
  14. DEPEND="${RDEPEND}
  15. sys-kernel/linux-headers"
  16. CONFIG_CHECK="~POSIX_MQUEUE"
  17. DOCS=( AUTHORS ChangeLog NEWS README )
  18. src_configure() {
  19. econf \
  20. $(use_enable static-libs static) \
  21. --libdir=/$(get_libdir) \
  22. --enable-libmount
  23. }
  24. src_install() {
  25. default
  26. rm -f "${ED}"/$(get_libdir)/*.la || die
  27. }