progsreiserfs-0.3.1_rc8.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic libtool
  5. MY_P=${PN}-${PV/_/-}
  6. DESCRIPTION="Library for accessing and manipulating reiserfs partitions"
  7. HOMEPAGE="http://reiserfs.linux.kiev.ua/"
  8. SRC_URI="http://reiserfs.linux.kiev.ua/snapshots/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86"
  12. IUSE="debug examples nls static-libs"
  13. RDEPEND=""
  14. DEPEND="${RDEPEND}
  15. sys-apps/util-linux
  16. nls? ( sys-devel/gettext )"
  17. S=${WORKDIR}/${MY_P}
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${P}-autotools.patch
  20. elibtoolize
  21. }
  22. src_configure() {
  23. filter-lfs-flags
  24. econf \
  25. $(use_enable static-libs static) \
  26. --disable-Werror \
  27. $(use_enable nls) \
  28. $(use_enable debug)
  29. }
  30. src_install() {
  31. default
  32. if use examples; then
  33. docinto examples
  34. dodoc demos/*.c
  35. fi
  36. rm -r "${ED}"/usr/{sbin,share/man} || die
  37. prune_libtool_files
  38. }
  39. pkg_postinst() {
  40. ewarn "progsreiserfs has been proven dangerous in the past, generating bad"
  41. ewarn "partitions and destroying data on resize/cpfs operations."
  42. ewarn "Because of this, we do NOT provide their binaries, but only their"
  43. ewarn "libraries instead, as these are needed for other applications."
  44. }