simple-mtpfs-9999.ebuild 670 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGIT_REPO_URI="git://github.com/phatina/${PN}.git"
  5. inherit autotools-utils eutils
  6. [[ ${PV} == 9999 ]] && inherit git-r3
  7. DESCRIPTION="Simple MTP fuse filesystem driver"
  8. HOMEPAGE="https://github.com/phatina/simple-mtpfs"
  9. [[ ${PV} == 9999 ]] || SRC_URI="https://github.com/phatina/${PN}/archive/${P}.tar.gz"
  10. LICENSE="GPL-2+"
  11. SLOT="0"
  12. [[ ${PV} == 9999 ]] || \
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. RDEPEND="
  16. media-libs/libmtp
  17. >=sys-fs/fuse-2.8
  18. "
  19. DEPEND="${RDEPEND}
  20. virtual/pkgconfig
  21. "
  22. [[ ${PV} == 9999 ]] || S="${WORKDIR}/${PN}-${P}"
  23. AUTOTOOLS_AUTORECONF=1