cygwin-crypt-1.4.ebuild 869 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="Cygwin Encryption/Decryption utility and library"
  6. HOMEPAGE="https://sourceware.org/cygwin-apps/"
  7. # Upstream provides the git repo only, so we do:
  8. # git clone git://cygwin.com/git/cygwin-apps/crypt.git
  9. # cd crypt
  10. # git archive -o cygwin-crypt-${PV}.tar --prefix=cygwin-crypt-${PV}/ crypt-${PV}-release
  11. # bzip2 cygwin-crypt-${PV}.tar
  12. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  13. LICENSE="GPL-2+"
  14. SLOT="0"
  15. KEYWORDS="~x64-cygwin ~x86-cygwin"
  16. IUSE=""
  17. DEPEND=""
  18. RDEPEND="${DEPEND}"
  19. mymake() {
  20. emake \
  21. CC="$(tc-getCC)" \
  22. AR="$(tc-getAR)" \
  23. CFLAGS="${CFLAGS}" \
  24. prefix="${EPREFIX}/usr" \
  25. docdir="${EPREFIX}/share/doc/${P}" \
  26. "$@"
  27. }
  28. src_compile() {
  29. mymake
  30. }
  31. src_install() {
  32. mymake install DESTDIR="${D}"
  33. }