db-4.2.52_p5-r1.ebuild 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
  4. #Number of official patches
  5. #PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
  6. PATCHNO=${PV/*.*.*_p}
  7. if [[ ${PATCHNO} == "${PV}" ]] ; then
  8. MY_PV=${PV}
  9. MY_P=${P}
  10. PATCHNO=0
  11. else
  12. MY_PV=${PV/_p${PATCHNO}}
  13. MY_P=${PN}-${MY_PV}
  14. fi
  15. S="${WORKDIR}/${MY_P}/build_unix"
  16. DESCRIPTION="Oracle Berkeley DB"
  17. HOMEPAGE="http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
  18. SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
  19. for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
  20. export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
  21. done
  22. LICENSE="Sleepycat"
  23. SLOT="4.2"
  24. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
  25. IUSE="tcl java doc cxx rpc"
  26. DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
  27. java? ( >=virtual/jdk-1.4 )"
  28. RDEPEND="tcl? ( dev-lang/tcl )
  29. java? ( >=virtual/jre-1.4 )"
  30. src_unpack() {
  31. unpack "${MY_P}".tar.gz
  32. cd "${WORKDIR}"/"${MY_P}"
  33. for (( i=1 ; i<=${PATCHNO} ; i++ ))
  34. do
  35. epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
  36. done
  37. epatch "${FILESDIR}"/"${PN}"-4.2.52_p2-TXN.patch
  38. epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
  39. # use the includes from the prefix
  40. epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-jni-check-prefix-first.patch
  41. epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-listen-to-java-options.patch
  42. epatch "${FILESDIR}"/"${PN}"-4.0.14-fix-dep-link.patch
  43. sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE
  44. # Include the SLOT for Java JAR files
  45. # This supersedes the unused jarlocation patches.
  46. sed -r -i \
  47. -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
  48. "${S}"/../dist/Makefile.in
  49. # START of 4.5+earlier specific
  50. # Upstream sucks, they normally concat these
  51. cd "${S}"/../dist/aclocal
  52. for i in *; do ln -s $i ${i%.ac}.m4 ; done ;
  53. cd "${S}"/../dist/aclocal_java
  54. for i in *; do ln -s $i ${i%.ac}.m4 ; done ;
  55. # END of 4.5+earlier specific
  56. cd "${S}"/../dist
  57. rm -f aclocal/libtool.{m4,ac} aclocal.m4
  58. sed -i \
  59. -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
  60. configure.ac
  61. sed -i \
  62. -e '/^AC_PATH_TOOL/s/ sh, missing_sh/ bash, missing_sh/' \
  63. aclocal/programs.m4
  64. AT_M4DIR="aclocal aclocal_java" eautoreconf
  65. # Upstream sucks - they do autoconf and THEN replace the version variables.
  66. . ./RELEASE
  67. sed -i \
  68. -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
  69. -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
  70. -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
  71. -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
  72. -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
  73. -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure
  74. }
  75. src_compile() {
  76. local myconf=""
  77. use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
  78. myconf="${myconf} $(use_enable cxx)"
  79. use tcl \
  80. && myconf="${myconf} --enable-tcl --with-tcl=${EPREFIX}/usr/$(get_libdir)" \
  81. || myconf="${myconf} --disable-tcl"
  82. myconf="${myconf} $(use_enable java)"
  83. if use java; then
  84. myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
  85. # Can't get this working any other way, since it returns spaces, and
  86. # bash doesn't seem to want to pass correctly in any way i try
  87. local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
  88. fi
  89. [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
  90. # the entire testsuite needs the TCL functionality
  91. if use tcl && use test; then
  92. myconf="${myconf} --enable-test"
  93. else
  94. myconf="${myconf} --disable-test"
  95. fi
  96. cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
  97. --prefix="${EPREFIX}"/usr \
  98. --mandir="${EPREFIX}"/usr/share/man \
  99. --infodir="${EPREFIX}"/usr/share/info \
  100. --datadir="${EPREFIX}"/usr/share \
  101. --sysconfdir="${EPREFIX}"/etc \
  102. --localstatedir="${EPREFIX}"/var/lib \
  103. --libdir="${EPREFIX}"/usr/"$(get_libdir)" \
  104. --enable-compat185 \
  105. --with-uniquename \
  106. $(use_enable rpc) \
  107. --host="${CHOST}" \
  108. ${myconf} "${javaconf}" || die "configure failed"
  109. # This isn't safe for prefix (Darwin should be .jnilib), but I can't get the
  110. # build system to behave itself, it generates libtool too late.
  111. sed -i \
  112. -e 's/-shrext $(SOFLAGS)/-shrext .so $(SOFLAGS)/g' \
  113. Makefile
  114. emake || die "make failed"
  115. }
  116. src_install() {
  117. einstall libdir="${ED}/usr/$(get_libdir)" strip="${ED}/bin/strip" || die
  118. db_src_install_usrbinslot
  119. db_src_install_headerslot
  120. db_src_install_doc
  121. db_src_install_usrlibcleanup
  122. dodir /usr/sbin
  123. # This file is not always built, and no longer exists as of db-4.8
  124. [[ -f "${ED}"/usr/bin/berkeley_db_svc ]] && \
  125. mv "${ED}"/usr/bin/berkeley_db_svc "${ED}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
  126. if use java; then
  127. java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
  128. java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
  129. rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
  130. fi
  131. }
  132. pkg_postinst() {
  133. db_fix_so
  134. }
  135. pkg_postrm() {
  136. db_fix_so
  137. }