db-4.6.21_p4.ebuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
  4. #Number of official patches
  5. #PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
  6. PATCHNO=${PV/*.*.*_p}
  7. if [[ ${PATCHNO} == "${PV}" ]] ; then
  8. MY_PV=${PV}
  9. MY_P=${P}
  10. PATCHNO=0
  11. else
  12. MY_PV=${PV/_p${PATCHNO}}
  13. MY_P=${PN}-${MY_PV}
  14. fi
  15. S="${WORKDIR}/${MY_P}/build_unix"
  16. DESCRIPTION="Oracle Berkeley DB"
  17. HOMEPAGE="http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
  18. SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
  19. for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
  20. export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
  21. done
  22. LICENSE="Sleepycat"
  23. SLOT="4.6"
  24. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
  25. IUSE="tcl java doc cxx rpc"
  26. DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
  27. java? ( >=virtual/jdk-1.4 )
  28. >=sys-devel/binutils-2.16.1"
  29. RDEPEND="tcl? ( dev-lang/tcl )
  30. java? ( >=virtual/jre-1.4 )"
  31. src_unpack() {
  32. unpack "${MY_P}".tar.gz
  33. cd "${WORKDIR}"/"${MY_P}"
  34. for (( i=1 ; i<=${PATCHNO} ; i++ ))
  35. do
  36. epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
  37. done
  38. epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
  39. # use the includes from the prefix
  40. epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-jni-check-prefix-first.patch
  41. epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
  42. sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE
  43. # Include the SLOT for Java JAR files
  44. # This supersedes the unused jarlocation patches.
  45. sed -r -i \
  46. -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
  47. "${S}"/../dist/Makefile.in
  48. cd "${S}"/../dist
  49. rm -f aclocal/libtool.m4
  50. sed -i \
  51. -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
  52. configure.ac
  53. sed -i \
  54. -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
  55. aclocal/programs.m4
  56. AT_M4DIR="aclocal aclocal_java" eautoreconf
  57. # Upstream sucks - they do autoconf and THEN replace the version variables.
  58. . ./RELEASE
  59. sed -i \
  60. -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
  61. -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
  62. -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
  63. -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
  64. -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
  65. -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure
  66. }
  67. src_compile() {
  68. # compilation with -O0 fails on amd64, see bug #171231
  69. if use amd64; then
  70. replace-flags -O0 -O2
  71. is-flagq -O[s123] || append-flags -O2
  72. fi
  73. local myconf=""
  74. use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
  75. myconf="${myconf} $(use_enable cxx)"
  76. use tcl \
  77. && myconf="${myconf} --enable-tcl --with-tcl=${EPREFIX}/usr/$(get_libdir)" \
  78. || myconf="${myconf} --disable-tcl"
  79. myconf="${myconf} $(use_enable java)"
  80. if use java; then
  81. myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
  82. # Can't get this working any other way, since it returns spaces, and
  83. # bash doesn't seem to want to pass correctly in any way i try
  84. local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
  85. fi
  86. [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
  87. # the entire testsuite needs the TCL functionality
  88. if use tcl && use test ; then
  89. myconf="${myconf} --enable-test"
  90. else
  91. myconf="${myconf} --disable-test"
  92. fi
  93. # Add linker versions to the symbols. Easier to do, and safer than header file
  94. # mumbo jumbo.
  95. if use userland_GNU; then
  96. append-ldflags -Wl,--default-symver
  97. fi
  98. cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
  99. --prefix="${EPREFIX}"/usr \
  100. --mandir="${EPREFIX}"/usr/share/man \
  101. --infodir="${EPREFIX}"/usr/share/info \
  102. --datadir="${EPREFIX}"/usr/share \
  103. --sysconfdir="${EPREFIX}"/etc \
  104. --localstatedir="${EPREFIX}"/var/lib \
  105. --libdir="${EPREFIX}"/usr/"$(get_libdir)" \
  106. --enable-compat185 \
  107. --enable-o_direct \
  108. --without-uniquename \
  109. $(use_enable rpc) \
  110. --host="${CHOST}" \
  111. ${myconf} "${javaconf}" || die "configure failed"
  112. sed -e "s,\(^STRIP *=\).*,\1\"true\"," Makefile > Makefile.cpy \
  113. && mv Makefile.cpy Makefile
  114. emake || die "make failed"
  115. }
  116. src_install() {
  117. einstall libdir="${ED}/usr/$(get_libdir)" STRIP="true" || die
  118. db_src_install_usrbinslot
  119. db_src_install_headerslot
  120. db_src_install_doc
  121. db_src_install_usrlibcleanup
  122. dodir /usr/sbin
  123. # This file is not always built, and no longer exists as of db-4.8
  124. [[ -f "${ED}"/usr/bin/berkeley_db_svc ]] && \
  125. mv "${ED}"/usr/bin/berkeley_db_svc "${ED}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
  126. if use java; then
  127. java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
  128. java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
  129. rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
  130. fi
  131. }
  132. pkg_postinst() {
  133. db_fix_so
  134. }
  135. pkg_postrm() {
  136. db_fix_so
  137. }