db-5.3.28-r2.ebuild 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib multilib-minimal toolchain-funcs
  5. #Number of official patches
  6. #PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
  7. PATCHNO=${PV/*.*.*_p}
  8. if [[ ${PATCHNO} == "${PV}" ]] ; then
  9. MY_PV=${PV}
  10. MY_P=${P}
  11. PATCHNO=0
  12. else
  13. MY_PV=${PV/_p${PATCHNO}}
  14. MY_P=${PN}-${MY_PV}
  15. fi
  16. S_BASE="${WORKDIR}/${MY_P}"
  17. S="${S_BASE}/build_unix"
  18. DESCRIPTION="Oracle Berkeley DB"
  19. HOMEPAGE="http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
  20. SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
  21. for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
  22. export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
  23. done
  24. LICENSE="Sleepycat"
  25. SLOT="5.3"
  26. KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh sparc x86 ~sparc-fbsd ~x86-fbsd"
  27. IUSE="doc java cxx tcl test"
  28. REQUIRED_USE="test? ( tcl )"
  29. # the entire testsuite needs the TCL functionality
  30. DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
  31. test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
  32. java? ( >=virtual/jdk-1.5 )
  33. >=sys-devel/binutils-2.16.1"
  34. RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
  35. java? ( >=virtual/jre-1.5 )"
  36. MULTILIB_WRAPPED_HEADERS=(
  37. /usr/include/db5.3/db.h
  38. )
  39. src_prepare() {
  40. cd "${WORKDIR}"/"${MY_P}"
  41. for (( i=1 ; i<=${PATCHNO} ; i++ ))
  42. do
  43. epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
  44. done
  45. # bug #510506
  46. epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
  47. # use the includes from the prefix
  48. epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
  49. epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
  50. # sqlite configure call has an extra leading ..
  51. # upstreamed:5.2.36, missing in 5.3.x
  52. epatch "${FILESDIR}"/${PN}-5.2.28-sqlite-configure-path.patch
  53. # The upstream testsuite copies .lib and the binaries for each parallel test
  54. # core, ~300MB each. This patch uses links instead, saves a lot of space.
  55. epatch "${FILESDIR}"/${PN}-6.0.20-test-link.patch
  56. # Needed when compiling with clang
  57. epatch "${FILESDIR}"/${PN}-5.1.29-rename-atomic-compare-exchange.patch
  58. # Upstream release script grabs the dates when the script was run, so lets
  59. # end-run them to keep the date the same.
  60. export REAL_DB_RELEASE_DATE="$(awk \
  61. '/^DB_VERSION_STRING=/{ gsub(".*\\(|\\).*","",$0); print $0; }' \
  62. "${S_BASE}"/dist/configure)"
  63. sed -r -i \
  64. -e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
  65. "${S_BASE}"/dist/RELEASE || die
  66. # Include the SLOT for Java JAR files
  67. # This supersedes the unused jarlocation patches.
  68. sed -r -i \
  69. -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
  70. "${S_BASE}"/dist/Makefile.in || die
  71. cd "${S_BASE}"/dist || die
  72. rm -f aclocal/libtool.m4
  73. sed -i \
  74. -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
  75. configure.ac || die
  76. sed -i \
  77. -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
  78. aclocal/programs.m4 || die
  79. AT_M4DIR="aclocal aclocal_java" eautoreconf
  80. # Upstream sucks - they do autoconf and THEN replace the version variables.
  81. . ./RELEASE
  82. for v in \
  83. DB_VERSION_{FAMILY,LETTER,RELEASE,MAJOR,MINOR} \
  84. DB_VERSION_{PATCH,FULL,UNIQUE_NAME,STRING,FULL_STRING} \
  85. DB_VERSION \
  86. DB_RELEASE_DATE ; do
  87. local ev="__EDIT_${v}__"
  88. sed -i -e "s/${ev}/${!v}/g" configure || die
  89. done
  90. }
  91. multilib_src_configure() {
  92. local myconf=()
  93. tc-ld-disable-gold #470634
  94. # compilation with -O0 fails on amd64, see bug #171231
  95. if [[ ${ABI} == amd64 ]]; then
  96. local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
  97. replace-flags -O0 -O2
  98. is-flagq -O[s123] || append-flags -O2
  99. fi
  100. # Add linker versions to the symbols. Easier to do, and safer than header file
  101. # mumbo jumbo.
  102. if use userland_GNU ; then
  103. append-ldflags -Wl,--default-symver
  104. fi
  105. # use `set` here since the java opts will contain whitespace
  106. if multilib_is_native_abi && use java ; then
  107. myconf+=(
  108. --with-java-prefix="${JAVA_HOME}"
  109. --with-javac-flags="$(java-pkg_javac-args)"
  110. )
  111. fi
  112. # Bug #270851: test needs TCL support
  113. if use tcl || use test ; then
  114. myconf+=(
  115. --enable-tcl
  116. --with-tcl="${EPREFIX}/usr/$(get_libdir)"
  117. )
  118. else
  119. myconf+=(--disable-tcl )
  120. fi
  121. # sql_compat will cause a collision with sqlite3
  122. # --enable-sql_compat
  123. ECONF_SOURCE="${S_BASE}"/dist \
  124. STRIP="true" \
  125. econf \
  126. --enable-compat185 \
  127. --enable-dbm \
  128. --enable-o_direct \
  129. --without-uniquename \
  130. --enable-sql \
  131. --enable-sql_codegen \
  132. --disable-sql_compat \
  133. $([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
  134. $([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
  135. $(use_enable cxx) \
  136. $(use_enable cxx stl) \
  137. $(multilib_native_use_enable java) \
  138. "${myconf[@]}" \
  139. $(use_enable test)
  140. }
  141. multilib_src_install() {
  142. emake install DESTDIR="${D}"
  143. db_src_install_headerslot
  144. db_src_install_usrlibcleanup
  145. if multilib_is_native_abi && use java; then
  146. java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
  147. java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
  148. rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
  149. fi
  150. }
  151. multilib_src_install_all() {
  152. db_src_install_usrbinslot
  153. db_src_install_doc
  154. dodir /usr/sbin
  155. # This file is not always built, and no longer exists as of db-4.8
  156. if [[ -f "${ED}"/usr/bin/berkeley_db_svc ]] ; then
  157. mv "${ED}"/usr/bin/berkeley_db_svc \
  158. "${ED}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
  159. fi
  160. }
  161. pkg_postinst() {
  162. multilib_foreach_abi db_fix_so
  163. }
  164. pkg_postrm() {
  165. multilib_foreach_abi db_fix_so
  166. }
  167. src_test() {
  168. # db_repsite is impossible to build, as upstream strips those sources.
  169. # db_repsite is used directly in the setup_site_prog,
  170. # setup_site_prog is called from open_site_prog
  171. # which is called only from tests in the multi_repmgr group.
  172. #sed -ri \
  173. # -e '/set subs/s,multi_repmgr,,g' \
  174. # "${S_BASE}/test/testparams.tcl"
  175. sed -ri \
  176. -e '/multi_repmgr/d' \
  177. "${S_BASE}/test/tcl/test.tcl" || die
  178. # This is the only failure in 5.2.28 so far, and looks like a false positive.
  179. # Repmgr018 (btree): Test of repmgr stats.
  180. # Repmgr018.a: Start a master.
  181. # Repmgr018.b: Start a client.
  182. # Repmgr018.c: Run some transactions at master.
  183. # Rep_test: btree 20 key/data pairs starting at 0
  184. # Rep_test.a: put/get loop
  185. # FAIL:07:05:59 (00:00:00) perm_no_failed_stat: expected 0, got 1
  186. sed -ri \
  187. -e '/set parms.*repmgr018/d' \
  188. -e 's/repmgr018//g' \
  189. "${S_BASE}/test/tcl/test.tcl" || die
  190. multilib-minimal_src_test
  191. }
  192. multilib_src_test() {
  193. multilib_is_native_abi || return
  194. S=${BUILD_DIR} db_src_test
  195. }