db-6.0.35.ebuild 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib multilib-minimal versionator toolchain-funcs
  5. #Number of official patches
  6. #PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
  7. PATCHNO=${PV/*.*.*_p}
  8. if [[ ${PATCHNO} == "${PV}" ]] ; then
  9. MY_PV=${PV}
  10. MY_P=${P}
  11. PATCHNO=0
  12. else
  13. MY_PV=${PV/_p${PATCHNO}}
  14. MY_P=${PN}-${MY_PV}
  15. fi
  16. S_BASE="${WORKDIR}/${MY_P}"
  17. S="${S_BASE}/build_unix"
  18. DESCRIPTION="Oracle Berkeley DB"
  19. HOMEPAGE="http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
  20. SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
  21. for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
  22. export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
  23. done
  24. LICENSE="AGPL-3"
  25. SLOT="$(get_version_component_range 1-2)"
  26. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
  27. IUSE="doc java cxx tcl test"
  28. REQUIRED_USE="test? ( tcl )"
  29. # the entire testsuite needs the TCL functionality
  30. DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
  31. test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
  32. java? ( >=virtual/jdk-1.5 )
  33. >=sys-devel/binutils-2.16.1"
  34. RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
  35. java? ( >=virtual/jre-1.5 )"
  36. MULTILIB_WRAPPED_HEADERS=(
  37. /usr/include/db$(get_version_component_range 1-2)/db.h
  38. )
  39. src_prepare() {
  40. cd "${WORKDIR}"/"${MY_P}"
  41. for (( i=1 ; i<=${PATCHNO} ; i++ ))
  42. do
  43. epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
  44. done
  45. # bug #510506
  46. epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
  47. # use the includes from the prefix
  48. epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
  49. epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
  50. # sqlite configure call has an extra leading ..
  51. # upstreamed:5.2.36, missing in 5.3.x/6.x
  52. # still needs to be patched in 6.0.20
  53. epatch "${FILESDIR}"/${PN}-6.0.35-sqlite-configure-path.patch
  54. # The upstream testsuite copies .lib and the binaries for each parallel test
  55. # core, ~300MB each. This patch uses links instead, saves a lot of space.
  56. epatch "${FILESDIR}"/${PN}-6.0.20-test-link.patch
  57. # Upstream release script grabs the dates when the script was run, so lets
  58. # end-run them to keep the date the same.
  59. export REAL_DB_RELEASE_DATE="$(awk \
  60. '/^DB_VERSION_STRING=/{ gsub(".*\\(|\\).*","",$0); print $0; }' \
  61. "${S_BASE}"/dist/configure)"
  62. sed -r -i \
  63. -e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
  64. "${S_BASE}"/dist/RELEASE || die
  65. # Include the SLOT for Java JAR files
  66. # This supersedes the unused jarlocation patches.
  67. sed -r -i \
  68. -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
  69. "${S_BASE}"/dist/Makefile.in || die
  70. cd "${S_BASE}"/dist || die
  71. rm -f aclocal/libtool.m4
  72. sed -i \
  73. -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
  74. configure.ac || die
  75. sed -i \
  76. -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
  77. aclocal/programs.m4 || die
  78. AT_M4DIR="aclocal aclocal_java" eautoreconf
  79. # Upstream sucks - they do autoconf and THEN replace the version variables.
  80. . ./RELEASE
  81. for v in \
  82. DB_VERSION_{FAMILY,LETTER,RELEASE,MAJOR,MINOR} \
  83. DB_VERSION_{PATCH,FULL,UNIQUE_NAME,STRING,FULL_STRING} \
  84. DB_VERSION \
  85. DB_RELEASE_DATE ; do
  86. local ev="__EDIT_${v}__"
  87. sed -i -e "s/${ev}/${!v}/g" configure || die
  88. done
  89. }
  90. multilib_src_configure() {
  91. local myconf=()
  92. tc-ld-disable-gold #470634
  93. # compilation with -O0 fails on amd64, see bug #171231
  94. if [[ ${ABI} == amd64 ]]; then
  95. local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
  96. replace-flags -O0 -O2
  97. is-flagq -O[s123] || append-flags -O2
  98. fi
  99. # Add linker versions to the symbols. Easier to do, and safer than header file
  100. # mumbo jumbo.
  101. if use userland_GNU ; then
  102. append-ldflags -Wl,--default-symver
  103. fi
  104. # use `set` here since the java opts will contain whitespace
  105. if multilib_is_native_abi && use java ; then
  106. myconf+=(
  107. --with-java-prefix="${JAVA_HOME}"
  108. --with-javac-flags="$(java-pkg_javac-args)"
  109. )
  110. fi
  111. # Bug #270851: test needs TCL support
  112. if use tcl || use test ; then
  113. myconf+=(
  114. --enable-tcl
  115. --with-tcl="${EPREFIX}/usr/$(get_libdir)"
  116. )
  117. else
  118. myconf+=(--disable-tcl )
  119. fi
  120. # sql_compat will cause a collision with sqlite3
  121. # --enable-sql_compat
  122. ECONF_SOURCE="${S_BASE}"/dist \
  123. STRIP="true" \
  124. econf \
  125. --enable-compat185 \
  126. --enable-dbm \
  127. --enable-o_direct \
  128. --without-uniquename \
  129. --enable-sql \
  130. --enable-sql_codegen \
  131. --disable-sql_compat \
  132. $([[ ${ABI} == arm ]] && echo --with-mutex=ARM/gcc-assembly) \
  133. $([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly) \
  134. $(use_enable cxx) \
  135. $(use_enable cxx stl) \
  136. $(multilib_native_use_enable java) \
  137. "${myconf[@]}" \
  138. $(use_enable test)
  139. }
  140. multilib_src_install() {
  141. emake install DESTDIR="${D}"
  142. db_src_install_headerslot
  143. db_src_install_usrlibcleanup
  144. if multilib_is_native_abi && use java; then
  145. java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
  146. java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
  147. rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
  148. fi
  149. }
  150. multilib_src_install_all() {
  151. db_src_install_usrbinslot
  152. db_src_install_doc
  153. dodir /usr/sbin
  154. # This file is not always built, and no longer exists as of db-4.8
  155. if [[ -f "${ED}"/usr/bin/berkeley_db_svc ]] ; then
  156. mv "${ED}"/usr/bin/berkeley_db_svc \
  157. "${ED}"/usr/sbin/berkeley_db"${SLOT/./}"_svc || die
  158. fi
  159. }
  160. pkg_postinst() {
  161. multilib_foreach_abi db_fix_so
  162. }
  163. pkg_postrm() {
  164. multilib_foreach_abi db_fix_so
  165. }
  166. src_test() {
  167. # db_repsite is impossible to build, as upstream strips those sources.
  168. # db_repsite is used directly in the setup_site_prog,
  169. # setup_site_prog is called from open_site_prog
  170. # which is called only from tests in the multi_repmgr group.
  171. #sed -ri \
  172. # -e '/set subs/s,multi_repmgr,,g' \
  173. # "${S_BASE}/test/testparams.tcl"
  174. sed -ri \
  175. -e '/multi_repmgr/d' \
  176. "${S_BASE}/test/tcl/test.tcl" || die
  177. # This is the only failure in 5.2.28 so far, and looks like a false positive.
  178. # Repmgr018 (btree): Test of repmgr stats.
  179. # Repmgr018.a: Start a master.
  180. # Repmgr018.b: Start a client.
  181. # Repmgr018.c: Run some transactions at master.
  182. # Rep_test: btree 20 key/data pairs starting at 0
  183. # Rep_test.a: put/get loop
  184. # FAIL:07:05:59 (00:00:00) perm_no_failed_stat: expected 0, got 1
  185. sed -ri \
  186. -e '/set parms.*repmgr018/d' \
  187. -e 's/repmgr018//g' \
  188. "${S_BASE}/test/tcl/test.tcl" || die
  189. multilib-minimal_src_test
  190. }
  191. multilib_src_test() {
  192. multilib_is_native_abi || return
  193. S=${BUILD_DIR} db_src_test
  194. }