fortify-headers-0.6.ebuild 624 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. if [[ ${PV} == "9999" ]] ; then
  5. EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
  6. inherit git-2
  7. else
  8. SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
  9. KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
  10. fi
  11. DESCRIPTION="A standalone implementation of fortify source."
  12. HOMEPAGE="http://git.2f30.org/fortify-headers/"
  13. LICENSE="ISC"
  14. SLOT="0"
  15. IUSE=""
  16. DEPEND=""
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. sed -i -e 's|^PREFIX = /usr/local|PREFIX = /usr|g' Makefile
  20. export DESTDIR="${D}"
  21. }