gwenhywfar-4.15.3.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_P="${P/_beta/beta}"
  5. DESCRIPTION="A multi-platform helper library for other libraries"
  6. HOMEPAGE="http://www.aquamaniac.de/aqbanking/"
  7. SRC_URI="http://www.aquamaniac.de/sites/download/download.php?package=01&release=201&file=01&dummy=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
  8. S="${WORKDIR}/${MY_P}"
  9. LICENSE="LGPL-2.1"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~hppa ppc ~ppc64 ~sparc x86"
  12. IUSE="debug doc fox gtk qt4"
  13. RDEPEND="dev-libs/libgpg-error
  14. >=dev-libs/libgcrypt-1.2.0:0
  15. dev-libs/openssl:0
  16. >=net-libs/gnutls-2.0.1
  17. virtual/libiconv
  18. virtual/libintl
  19. fox? ( x11-libs/fox:1.6 )
  20. gtk? ( >=x11-libs/gtk+-2.17.5:2 )
  21. qt4? ( dev-qt/qtgui:4 )"
  22. DEPEND="${RDEPEND}
  23. virtual/pkgconfig
  24. sys-devel/gettext
  25. doc? ( app-doc/doxygen )"
  26. # broken upstream, reported but got no reply
  27. RESTRICT="test"
  28. src_configure() {
  29. local guis
  30. use fox && guis="${guis} fox16"
  31. use gtk && guis="${guis} gtk2"
  32. use qt4 && guis="${guis} qt4"
  33. econf \
  34. --enable-ssl \
  35. --enable-visibility \
  36. $(use_enable debug) \
  37. $(use_enable doc full-doc) \
  38. --with-guis="${guis}" \
  39. --with-docpath=/usr/share/doc/${PF}/apidoc
  40. }
  41. src_compile() {
  42. emake
  43. use doc && emake srcdoc
  44. }
  45. src_install() {
  46. emake DESTDIR="${D}" install
  47. use doc && emake DESTDIR="${D}" install-srcdoc
  48. dodoc AUTHORS ChangeLog README TODO
  49. find "${ED}" -name '*.la' -exec rm -f {} +
  50. }