gwenhywfar-4.3.3.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="A multi-platform helper library for other libraries"
  5. HOMEPAGE="http://www.aquamaniac.de/aqbanking/"
  6. SRC_URI="http://www.aquamaniac.de/sites/download/download.php?package=01&release=67&file=01&dummy=${P}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="amd64 hppa ppc ~ppc64 ~sparc x86"
  10. IUSE="debug doc fox gtk qt4"
  11. RDEPEND="dev-libs/libgpg-error
  12. >=dev-libs/libgcrypt-1.2.0:0
  13. dev-libs/openssl:0
  14. >=net-libs/gnutls-2.0.1
  15. virtual/libiconv
  16. virtual/libintl
  17. fox? ( x11-libs/fox:1.6 )
  18. gtk? ( >=x11-libs/gtk+-2.17.5:2 )
  19. qt4? ( dev-qt/qtgui:4 )"
  20. DEPEND="${RDEPEND}
  21. virtual/pkgconfig
  22. sys-devel/gettext
  23. doc? ( app-doc/doxygen )"
  24. # broken upstream, reported but got no reply
  25. RESTRICT="test"
  26. src_configure() {
  27. local guis
  28. use fox && guis="${guis} fox16"
  29. use gtk && guis="${guis} gtk2"
  30. use qt4 && guis="${guis} qt4"
  31. econf \
  32. --enable-ssl \
  33. --enable-visibility \
  34. $(use_enable debug) \
  35. $(use_enable doc full-doc) \
  36. --with-guis="${guis}" \
  37. --with-docpath=/usr/share/doc/${PF}/apidoc
  38. }
  39. src_compile() {
  40. emake
  41. use doc && emake srcdoc
  42. }
  43. src_install() {
  44. emake DESTDIR="${D}" install
  45. use doc && emake DESTDIR="${D}" install-srcdoc
  46. dodoc AUTHORS ChangeLog README TODO
  47. find "${ED}" -name '*.la' -exec rm -f {} +
  48. }