lib-compat-1.4.2-r1.ebuild 622 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Compatibility C++ and libc5 and libc6 libraries for very old programs"
  5. HOMEPAGE="https://www.gentoo.org/"
  6. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. RDEPEND="!<=app-emulation/emul-linux-x86-compat-20140508"
  11. src_install() {
  12. if use amd64 || use x86; then
  13. cd x86 || die
  14. ABI=x86
  15. into /
  16. dolib.so ld-linux.so.1*
  17. rm -f ld-linux.so.1*
  18. #elif use alpha; then
  19. # cd alpha || die
  20. else
  21. die "arch not supported"
  22. fi
  23. into /usr
  24. dolib.so *.so*
  25. }