libieee1284-0.2.11-r4.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-single-r1 multilib-minimal
  6. DESCRIPTION="Library to query devices using IEEE1284"
  7. HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
  8. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  12. IUSE="doc python static-libs"
  13. RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r9
  14. !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )
  15. python? ( ${PYTHON_DEPS} )"
  16. DEPEND="${RDEPEND}
  17. doc? (
  18. app-text/docbook-sgml-utils
  19. >=app-text/docbook-sgml-dtd-4.1
  20. app-text/docbook-dsssl-stylesheets
  21. dev-perl/XML-RegExp
  22. )"
  23. DOCS="AUTHORS NEWS README* TODO doc/interface*"
  24. pkg_setup() {
  25. use python && python-single-r1_pkg_setup
  26. }
  27. multilib_src_configure() {
  28. local myconf="--without-python"
  29. multilib_is_native_abi && myconf="$(use_with python)"
  30. ECONF_SOURCE="${S}" econf \
  31. --enable-shared \
  32. $(use_enable static-libs static) \
  33. ${myconf}
  34. }
  35. multilib_src_install_all() {
  36. prune_libtool_files --all
  37. einstalldocs
  38. }