libmath++-0.0.4-r1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. AUTOTOOLS_IN_SOURCE_BUILD=1 # bug #474098
  6. inherit autotools-utils
  7. DESCRIPTION="template based math library, written in C++, for symbolic and numeric calculus applications"
  8. HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
  9. SRC_URI="mirror://gentoo/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="1"
  12. KEYWORDS="amd64 ppc ~s390 x86"
  13. IUSE="doc static-libs"
  14. DEPEND="doc? ( app-doc/doxygen )"
  15. RDEPEND=""
  16. DOCS=( AUTHORS README TODO )
  17. src_prepare() {
  18. # Autotools 1.13 compatibility, bug #471950
  19. sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in || die 'sed on configure.in failed'
  20. autotools-utils_src_prepare
  21. }
  22. src_compile() {
  23. autotools-utils_src_compile
  24. if use doc; then
  25. pushd "${AUTOTOOLS_BUILD_DIR}" >/dev/null
  26. emake -C doc api-doc
  27. popd >/dev/null
  28. fi
  29. }
  30. src_install() {
  31. autotools-utils_src_install
  32. if use doc; then
  33. pushd "${AUTOTOOLS_BUILD_DIR}" >/dev/null
  34. dohtml -r doc/user-api/*
  35. popd >/dev/null
  36. fi
  37. }